addUnquantizedVertex Method
Add a vertex to the mesh and return its index in positions.
addUnquantizedVertex(position: Readonly<WritableXYAndZ>, uv: Readonly<WritableXAndY>, normal?: Readonly<WritableXYAndZ>): number
@see addQuantizedVertex if your vertex data is already quantized.
@returns the index of the new vertex in positions.
Parameter | Type | Description |
---|---|---|
position | Readonly<WritableXYAndZ> | The 3d position, which will be quantized to the positionRange supplied to the builder's constructor. |
uv | Readonly<WritableXAndY> | The texture coordinates, which will be quantized to the uvRange supplied to the builder's constructor. |
normal | Readonly<WritableXYAndZ> |
Returns - number
the index of the new vertex in positions.
Defined in
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.