MeshArgs Interface
Arguments supplied to createTriMesh describing a triangle mesh.
Properties
Name | Type | Description | |
---|---|---|---|
auxChannels | ReadonlyArray<AuxChannel> | undefined | Auxiliary data associated with the mesh. | |
colors | ColorIndex | The color(s) of the mesh. | |
features | FeatureIndex | The Feature(s) contained in the mesh. | |
fillFlags | FillFlags | undefined | If isPlanar is true , describes how fill is applied to planar region interiors in wireframe mode. |
|
hasBakedLighting | boolean | undefined | If true , indicates that the mesh has a texture that includes static lighting - e.g., from photogrammetry. |
|
is2d | boolean | undefined | If true , indicates that the mesh is two-dimensional - i.e., all points have the same z coordinate. |
|
isPlanar | boolean | undefined | If true , indicates that the mesh represents a planar region. |
|
material | RenderMaterial | undefined | The material applied to the mesh. | |
normals | OctEncodedNormal[] | undefined | The per-vertex normal vectors, indexed by vertIndices. | |
points | QPoint3dList | Point3d[] & { range: Range3d } | The positions of the mesh's vertices, indexed by vertIndices. | |
textureMapping | { texture: RenderTexture, uvParams: Point2d[] } | undefined | A texture mapping to be applied to the mesh. | |
vertIndices | number[] | The indices of the triangles. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.