setSymbology Method
Sets the current active symbology for this builder. Any new geometry subsequently added will be drawn using the specified symbology.
setSymbology(lineColor: ColorDef, fillColor: ColorDef, lineWidth: number, linePixels: LinePixelsLinePixels.Solid): void
@see activateGraphicParams for additional symbology options.
Parameter | Type | Description |
---|---|---|
lineColor | ColorDef | The color in which to draw lines. |
fillColor | ColorDef | The color in which to draw filled regions. |
lineWidth | number | The width in pixels to draw lines. The renderer will clamp this value to an integer in the range [1, 32]. |
linePixels | LinePixels | The pixel pattern in which to draw lines. |
Returns - void
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.