extractImageSourceDimensions Function
Extract the dimensions of the jpeg or png data encoded in an ImageSource.
extractImageSourceDimensions(source: ImageSource): Promise<Point2d>
@returns a Promise resolving to a Point2d of which x corresponds to the integer width of the uncompressed bitmap and y to the height.
Parameter | Type | Description |
---|---|---|
source | ImageSource | The ImageSource containing the binary jpeg or png data. |
Returns - Promise<Point2d>
a Promise resolving to a Point2d of which x corresponds to the integer width of the uncompressed bitmap and y to the height.
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.