overrideSelectedElements Method
Set the currently selected elements to display with a color/transparency override.
overrideSelectedElements(vp: Viewport, color: ColorDef, override: FeatureOverrideTypeFeatureOverrideType.ColorOnly, replace: booleanfalse, clearSelection: booleantrue): boolean
@returns true if overrides were changed.
@see addFeatureOverrideProvider
Parameter | Type | Description |
---|---|---|
vp | Viewport | The viewport. |
color | ColorDef | ColorDef to specify override rgb and alpha. |
override | FeatureOverrideType | Whether to use color and alpha, only color, or only alpha from the supplied ColorDef. |
replace | boolean | true to replace currently overridden elements (if any) or false to add to the existing set. |
clearSelection | boolean | true to clear current selection after setting appearance override, false to leave selected. |
Returns - boolean
true if overrides were changed.
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.