MapLayerFormatRegistry Class
A registry of MapLayerFormats identified by their unique format IDs. The registry can be accessed via mapLayerFormatRegistry.
Methods
Name | Description | |
---|---|---|
constructor(opts?: MapLayerOptions): MapLayerFormatRegistry | ||
getAccessClient(formatId: string): undefined | MapLayerAccessClient | ||
isRegistered(formatId: string): boolean | ||
register(formatClass: ): void | ||
setAccessClient(formatId: string, accessClient: MapLayerAccessClient): boolean | ||
validateSource(opts: ValidateSourceArgs): Promise<MapLayerSourceValidation> | ||
validateSource(formatId: string, url: string, userName?: string, password?: string, ignoreCache?: boolean): Promise<MapLayerSourceValidation> |
Properties
Name | Type | Description | |
---|---|---|---|
configOptions Accessor ReadOnly | MapLayerOptions |
Defined in
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.