TentativeOrAccuSnap Class
TentativeOrAccuSnap returns information about an active snap generated by either AccuSnap or TentativePoint.
Methods
Name | Description | |
---|---|---|
constructor(): TentativeOrAccuSnap | ||
getCurrentPoint(): Point3d Static | ||
getCurrentSnap(checkIsHot: booleantrue): undefined | SnapDetail Static | Get the current snap from either AccuSnap or TentativePoint. | |
getCurrentView(): undefined | ScreenViewport Static |
Properties
Name | Type | Description | |
---|---|---|---|
isHot Accessor Static ReadOnly | boolean |
Defined in
- core/frontend/src/AccuSnap.ts Line 1180
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.