constructor Method
HitDetail(props)
Create a new HitDetail from the inputs to and results of a locate operation.
HitDetail(props: HitDetailProps): HitDetail
Parameter | Type | Description |
---|---|---|
props | HitDetailProps |
Returns - HitDetail
HitDetail(testPoint, viewport, hitSource, hitPoint, sourceId, priority, distXY, distFraction, subCategoryId?, geometryClass?, modelId?, sourceIModel?, tileId?, isClassifier?)
Deprecated in 4.1. Use the overload that takes a HitDetailProps.
HitDetail(testPoint: Point3d, viewport: ScreenViewport, hitSource: HitSource, hitPoint: Point3d, sourceId: string, priority: HitPriority, distXY: number, distFraction: number, subCategoryId?: string, geometryClass?: GeometryClass, modelId?: string, sourceIModel?: IModelConnection, tileId?: string, isClassifier?: boolean): HitDetail
Parameter | Type | Description |
---|---|---|
testPoint | Point3d | |
viewport | ScreenViewport | |
hitSource | HitSource | |
hitPoint | Point3d | |
sourceId | string | |
priority | HitPriority | |
distXY | number | |
distFraction | number | |
subCategoryId | string | |
geometryClass | GeometryClass | |
modelId | string | |
sourceIModel | IModelConnection | |
tileId | string | |
isClassifier | boolean |
Returns - HitDetail
Defined in
- core/frontend/src/HitDetail.ts Line 250
Last Updated: 25 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.