CatalogConnection.openEditable Function

Open a CatalogIModel for write access.

openEditable(args: CatalogIModel.OpenArgs): Promise<EditableCatalogConnection>

@note Once a version of a CatalogIModel has been published (i.e. the write lock has been released), it is no longer editable, unless it is a prerelease version.

@note the write lock must be held for this operation to succeed

Parameter Type Description
args CatalogIModel.OpenArgs  

Returns - Promise<EditableCatalogConnection>

Defined in

Last Updated: 26 April, 2025