CatalogIModel.OpenArgs Interface
Arguments to open an existing version of a CatalogIModel.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
containerId | string | undefined | The ContainerId of the cloud container. | |
prefetch | boolean | undefined | Start a prefetch operation on the CatalogIModel as it is opened. | |
syncWithCloud | boolean | undefined | If true, attempt to synchronize the container with any changes in the cloud. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
dbName Readonly Inherited | string | undefined | CatalogIModel.NameAndVersion | The name of the catalog database. |
key Readonly Inherited | string | undefined | SnapshotOpenOptions | |
version Readonly Inherited | string | undefined | CatalogIModel.NameAndVersion | The range of acceptable versions of the database of the specified NameAndVersion.dbName. |
Defined in
- core/common/src/CatalogIModel.ts Line 112
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.