CatalogConnection.createNewVersion Function

Create a new version of a CatalogIModel as a copy of an existing version. Immediately after this operation, the new version will be an exact copy of the source CatalogIModel. Then, use openEditable to modify the new version with new content.

createNewVersion(args: CatalogIModel.CreateNewVersionArgs): Promise<{ newDb: CatalogIModel.NameAndVersion, oldDb: CatalogIModel.NameAndVersion }>

@note the write lock must be held for this operation to succeed

@see acquireWriteLock

Parameter Type Description
args CatalogIModel.CreateNewVersionArgs  

Returns - Promise<{ newDb: CatalogIModel.NameAndVersion, oldDb: CatalogIModel.NameAndVersion }>

Defined in

Last Updated: 26 April, 2025