CatalogIModel.CreateNewVersionArgs Interface

Arguments to create a new version of a CatalogIModel from (a copy of) an existing version in a cloud container.

Properties

Name Type Description
containerId Readonly string The id of cloud container.  
fromDb Readonly CatalogIModel.NameAndVersion the source version of the CatalogIModel, from which the new version will copied.  
identifier Readonly string | undefined For prerelease versions, a string that becomes part of the version name.  
versionType Readonly "major" | "minor" | "patch" | "premajor" | "preminor" | "prepatch" | "prerelease" The type of version increment to apply to the source version.  

Defined in

Last Updated: 26 April, 2025