NoRenderApp Class
A utility class intended for applications (primarily test-runners) that run in environments that lack support for WebGL. It installs a RenderSystem that produces no graphics. Use startup instead of startup to initialize your application frontend. You may then use the IModelApp API as normal.
Methods
Name | Description | |
---|---|---|
constructor(): NoRenderApp | ||
startup(opts?: IModelAppOptions): Promise<void> Static | Initializes IModelApp with a RenderSystem that produces no graphics. |
Defined in
- core/frontend/src/NoRenderApp.ts Line 76
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.