ElectronApp Class

Frontend of an Electron App.

Methods

Name Description
constructor(): ElectronApp    
shutdown(): Promise<void> Static    
startup(opts?: NativeAppOpts): Promise<void> Static Start the frontend of an Electron application.  

Properties

Name Type Description
dialogIpc Static PickAsyncMethods<Electron.Dialog> Proxy object for calling methods of Electron.Dialog  
isValid Accessor Static ReadOnly boolean    

Defined in

Last Updated: 21 November, 2024