startup MethodStatic
Initialize the backend of an Electron app. This method configures the backend for all of the inter-process communication (RPC and IPC) for an Electron app. It should be called from your Electron main function.
startup(opts?: ElectronHostOpts): Promise<void>
@note This method must only be called from the backend of an Electron app (i.e. when ProcessDetector.isElectronAppBackend is true
).
Parameter | Type | Description |
---|---|---|
opts | ElectronHostOpts | Options that control aspects of your backend. |
Returns - Promise
Defined in
- electron/src/backend/ElectronHost.ts Line 268
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.