ViewDetailsProps Interface
Properties of a ViewDefinitionProps stored as JSON.
@see - jsonProperties.
- ViewDetails3dProps for additional properties specific to 3d views.
Properties
Name | Type | Description | |
---|---|---|---|
acs | string | undefined | Id of the aux coord system. | |
aspectSkew | number | undefined | Aspect ratio skew (x/y) used to exaggerate the y axis of the view. | |
clip | ClipVectorProps | undefined | Describes the ClipVector applied to the view. | |
gridOrient | GridOrientationType | undefined | Grid orientation. | |
gridPerRef | number | undefined | Default: 10. | |
gridSpaceX | number | undefined | Default: 1.0. | |
gridSpaceY | number | undefined | Default: same as gridSpaceX. |
Defined in
- core/common/src/ViewDetails.ts Line 19
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.