ViewDetails3dProps Interface
Properties of a ViewDefinition3dProps stored as JSON.
@see jsonProperties.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
disable3dManipulations | boolean | undefined | Whether viewing tools are prohibited from operating in 3 dimensions on this view. | |
modelClipGroups | ModelClipGroupProps[] | undefined | Defines how to clip groups of models. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
acs Inherited | string | undefined | ViewDetailsProps | Id of the aux coord system. |
aspectSkew Inherited | number | undefined | ViewDetailsProps | Aspect ratio skew (x/y) used to exaggerate the y axis of the view. |
clip Inherited | ClipVectorProps | undefined | ViewDetailsProps | Describes the ClipVector applied to the view. |
gridOrient Inherited | GridOrientationType | undefined | ViewDetailsProps | Grid orientation. |
gridPerRef Inherited | number | undefined | ViewDetailsProps | Default: 10. |
gridSpaceX Inherited | number | undefined | ViewDetailsProps | Default: 1.0. |
gridSpaceY Inherited | number | undefined | ViewDetailsProps | Default: same as gridSpaceX. |
Defined in
- core/common/src/ViewDetails.ts Line 58
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.