ViewDefinition2dProps Interface
Parameters used to construct a ViewDefinition2d
Extends
Properties
Name | Type | Description | |
---|---|---|---|
angle | AngleProps | ||
baseModelId | string | ||
delta | XYProps | ||
origin | XYProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categorySelectorId Inherited | string | ViewDefinitionProps | |
classFullName Inherited | string | ViewDefinitionProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code Inherited | CodeProps | ViewDefinitionProps | The Code for this element |
description Inherited | string | undefined | ViewDefinitionProps | |
displayStyleId Inherited | string | ViewDefinitionProps | |
federationGuid Inherited | string | undefined | ViewDefinitionProps | A FederationGuid assigned to this element. |
id Inherited | string | undefined | ViewDefinitionProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | ViewDefinitionProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate Inherited | boolean | undefined | ViewDefinitionProps | |
jsonProperties Inherited | { viewDetails?: ViewDetailsProps } | undefined | ViewDefinitionProps | Optional json properties of this element. |
model Inherited | string | ViewDefinitionProps | The Id of the Model containing this element |
parent Inherited | RelatedElementProps | undefined | ViewDefinitionProps | The Parent of this element, if defined. |
userLabel Inherited | string | undefined | ViewDefinitionProps | A user-assigned label for this element. |
Defined in
- core/common/src/ViewProps.ts Line 205
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.