ClipStyle Class
Describes symbology and behavior applied to a ClipVector when applied to a ViewState or ModelClipGroup.
@see clipStyle.
Methods
Name | Description | |
---|---|---|
toJSON(): undefined | ClipStyleProps | The JSON representation of this style. | |
fromJSON(props?: ClipStyleProps): ClipStyle Static |
Properties
Name | Type | Description | |
---|---|---|---|
colorizeIntersection Readonly | boolean | If 'true', intersection of geometry and clip planes will be colorized | |
cutStyle Readonly | CutStyle | Controls aspects of how the cut geometry is displayed, if produceCutGeometry is true . |
|
defaults Static Readonly | ClipStyle | The default style, which overrides none of the view's settings. | |
insideColor Readonly | RgbColor | undefined | If defined, geometry inside the clip planes will be drawn in this color. | |
intersectionStyle Readonly | ClipIntersectionStyle | undefined | Controls the style of the intersection of geometry and clip planes | |
matchesDefaults Accessor ReadOnly | boolean | Returns true if this style matches the defaults - that is, it overrides no settings from the view. | |
outsideColor Readonly | RgbColor | undefined | If defined, geometry outside of the clip planes will be drawn in this color instead of being clipped. | |
produceCutGeometry Readonly | boolean | If true , geometry will be produced at the clip planes. |
Defined in
- core/common/src/ClipStyle.ts Line 224
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.