HSVColor Class
An immutable color defined by Hue, Saturation, and Value
@see here for difference between HSL and HSV
Methods
Name | Description | |
---|---|---|
constructor(hue: number0, saturation: number0, value: number0): HSVColor | ||
adjusted(darkenColor: boolean, delta: number): HSVColor | ||
clone(hue?: number, saturation?: number, value?: number): HSVColor | ||
toColorDef(transparency: number0): ColorDef | ||
fromColorDef(val: ColorDef): HSVColor Static |
Properties
Name | Type | Description | |
---|---|---|---|
h Readonly | number | Hue | |
s Readonly | number | Saturation | |
v Readonly | number | Value |
Defined in
- core/common/src/HSVColor.ts Line 25
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.