TextureMapProps Interface
As part of a RenderMaterialAssetProps, describes how to map a RenderTexture's image to the triangles of a mesh to which the material is applied.
@see RenderMaterialAssetMapsProps for the supported types of texture mappings.
Properties
Name | Type | Description | |
---|---|---|---|
pattern_angle | number | undefined | Angle in degrees to rotate texture when applying; defaults to 0.0 if undefined | |
pattern_constantlod_maxdistanceclamp | number | undefined | The maximum distance (from the eye to the surface) at which to clamp the texture size when pattern_useconstantlod is true. | |
pattern_constantlod_mindistanceclamp | number | undefined | The minimum distance (from the eye to the surface) at which to clamp the texture size when pattern_useconstantlod is true. | |
pattern_constantlod_offset | Point2dProps | undefined | An offset in world units used to shift the texture when pattern_useconstantlod is true. | |
pattern_constantlod_repetitions | number | undefined | The number of times the texture is repeated if pattern_useconstantlod is true. | |
pattern_flip | boolean | undefined | If true, flip the pattern map in V; if undefined, defaults to false | |
pattern_mapping | TextureMapping.Mode | undefined | Mapping mode to use for the texture application; if undefined, defaults to TextureMapping.Mode.Parametric | |
pattern_offset | Point2dProps | undefined | X, Y offset to apply to the pattern map; if undefined, defaults to {0,0} | |
pattern_scale | Point2dProps | undefined | X, Y scale to apply to the pattern map; if undefined, defaults to {0,0}, which is almost never useful. | |
pattern_scalemode | TextureMapUnits | undefined | Units to use when applying the scaling; if undefined, defaults to Relative | |
pattern_u_flip | boolean | undefined | If true, flip the pattern map in U; if undefined, defaults to false | |
pattern_useconstantlod | boolean | undefined | If true, override the mapping mode with constant LOD mapping for the normal map, defaults to false. | |
pattern_useConstantLod | boolean | undefined | If true, override the mapping mode with constant LOD mapping for the normal map, defaults to false. | Deprecated |
pattern_weight | number | undefined | Weight at which to combine diffuse image and color; if undefined, defaults to 1.0 | |
TextureId | string | The Id of the persistent Texture element defining the texture image. |
Defined in
- core/common/src/MaterialProps.ts Line 48
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.