RenderMaterialAssetMapsProps Interface
Describes different types of textures to be applied to a surface material to alter its appearance.
@note While technically both Pattern and Normal can define their own mapping parameters (pattern_angle
, pattern_mapping
, etc), in practice
if both maps are present they are expected to have identical mapping parameters, with the exception of TextureId
.
@see RenderMaterialAssetProps.Map to define the texture maps for a material asset.
Properties
Name | Type | Description | |
---|---|---|---|
Bump | TextureMapProps | undefined | Maps an image describing detailed minor height variation of the surface geometry. | |
Diffuse | TextureMapProps | undefined | Maps an image describing the diffuse color of the surface, replacing or mixing with the surface's own color. | |
Displacement | TextureMapProps | undefined | Maps an image describing the displacement of the surface geometry | |
Finish | TextureMapProps | undefined | Maps an image describing the glossiness of the surface's finish | |
GlowColor | TextureMapProps | undefined | Maps an image describing glowing parts of the surface | |
Normal | NormalMapProps | undefined | Maps a normal map to the surface, simulating more complex surface details than are | |
Pattern | TextureMapProps | undefined | Maps an image describing the diffuse color of the surface, replacing or mixing with the surface's own color. | |
Reflect | TextureMapProps | undefined | Maps an image describing the reflectiveness of the surface | |
Specular | TextureMapProps | undefined | Maps an image describing the specular component of the surface | |
TranslucencyColor | TextureMapProps | undefined | Maps an image describing the translucency of the surface, how much light comes out the back of the surface | |
TransparentColor | TextureMapProps | undefined | Maps an image describing the transparency of the surface, how visible objects behind this object are |
Defined in
- core/common/src/MaterialProps.ts Line 112
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.