TxnAction Enumeration
Describes the types of actions associated with Txns.
Members
Name | Value | Description |
---|---|---|
Abandon | Abandoning the current Txn, e.g., via IModelDb.abandonChanges. | |
Commit | Processing a commit initiated by a call to IModelDb.saveChanges or BriefcaseConnection.saveChanges. | |
Merge | Merging a changeset produced by a different briefcase, e.g., via BriefcaseDb.pullChanges. | |
None | Not currently processing anything. | |
Reinstate | Reinstating a previously reversed changeset, e.g., via TxnManager.reinstateTxn or BriefcaseTxns.reinstateTxn. | |
Reverse | Reversing a previously-committed changeset, e.g., via TxnManager.reverseTxns BriefcaseTxns.reverseTxns. |
Defined in
- core/common/src/TxnAction.ts Line 13
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.