saveChanges Method
Commit unsaved changes in memory as a Txn to this iModelDb.
saveChanges(description?: string): void
@throws IModelError if there is a problem saving changes or if there are pending, un-processed lock or code requests.
@note This will not push changes to the iModelHub.
@see pushChanges to push changes to the iModelHub.
Parameter | Type | Description |
---|---|---|
description | string | Optional description of the changes |
Returns - void
Defined in
- core/backend/src/IModelDb.ts Line 784
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.