InUseLocksError.isInUseLocksError Function
type guard function that returns whether or not the passed in parameter is an InUseLocksError. it first checks isITwinError and then checks that the namespace property is "itwinjs-core" and the errorKey property is "in-use-locks".
isInUseLocksError(error: unknown): error is InUseLocksError
Parameter | Type | Description |
---|---|---|
error | unknown |
Returns - error is InUseLocksError
Defined in
- core/common/src/ITwinError.ts Line 71
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.