InUseLocksError Namespace
Function
Name | Description |
---|---|
InUseLocksError.isInUseLocksError | type guard function that returns whether or not the passed in parameter is an InUseLocksError. |
InUseLocksError.throwInUseLocksError | throws an error which passes the isInUseLocksError type guard function |
Defined in
- core/common/src/ITwinError.ts Line 58
InUseLocksError Interface
An error raised when there is a lock conflict detected. Typically this error would be thrown by LockControl.acquireLocks when you are requesting a lock on an element that is already held by another briefcase.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
errorKey | "in-use-locks" | unique key for error, within namespace. | |
inUseLocks | InUseLock[] | ||
namespace | "itwinjs-core" | namespace for the error. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
string | ITwinError | explanation of what went wrong. | |
metadata Inherited | LoggingMetaData | undefined | ITwinError | metadata about the exception. |
stack Inherited | string | undefined | ITwinError | stack trace of the error. |
Defined in
- core/common/src/ITwinError.ts Line 58
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.