CloudSqliteError.WriteLockHeld Interface
thrown when an attempt to acquire the write lock for a container fails because the lock is already held by somebody else ("write-lock-held").
Extends
Properties
Name | Type | Description | |
---|---|---|---|
expires | string | time the lock expires | |
lockedBy | string | moniker of user currently holding container's lock |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
containerId Readonly Inherited | string | undefined | CloudSqliteError | The name of the container associated with the error |
dbName Readonly Inherited | string | undefined | CloudSqliteError | The name of the database that generated the error |
iTwinErrorId Readonly Inherited | ITwinErrorId | CloudSqliteError | Uniquely identifies the kind of error. |
Defined in
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.