CloudSqliteError Namespace

Interface

Name Description
CloudSqliteError.WriteLockHeld thrown when an attempt to acquire the write lock for a container fails because the lock is already held by somebody else ("write-lock-held").

Type alias

Name Description
CloudSqliteError.Key  

Variable

Name Description
CloudSqliteError.scope  

Function

Name Description
CloudSqliteError.isError Determine whether an error object is a CloudSqliteError
CloudSqliteError.throwError Instantiate and throw a CloudSqliteError

Defined in

CloudSqliteError Interface

An error originating from the CloudSqlite API.

Extends

Properties

Name Type Description
containerId Readonly string | undefined The name of the container associated with the error  
dbName Readonly string | undefined The name of the database that generated the error  

Inherited properties

Name Type Inherited from Description
iTwinErrorId Readonly Inherited ITwinErrorId ITwinError Uniquely identifies the kind of error.

Defined in

Last Updated: 26 April, 2025