QPoint3dBuffer Namespace
Function
Name | Description |
---|---|
QPoint3dBuffer.getQPoint | Extracts the point at the specified index from a buffer. |
QPoint3dBuffer.unquantizePoint | Extracts and unquantizes the point at the specified index from a buffer. |
Defined in
- core/common/src/QPoint.ts Line 683
QPoint3dBuffer Interface
A compact representation of a list of QPoint3ds stored in a Uint16Array
.
This representation is particularly useful when passing data to WebGL; for example, see RealityMeshParams.positions.
Properties
Name | Type | Description | |
---|---|---|---|
params | QParams3d | The parameters used to quantize the points. | |
points | Uint16Array | The QPoint3ds as pairs of unsigned 16-bit integers. |
Defined in
- core/common/src/QPoint.ts Line 683
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.