QParams3d Class

Parameters used for Quantization of 3d points such that the x, y, and z components are each quantized to 16-bit unsigned integers.

@see - QPoint3d for the quantized representation of a Point3d.

Methods

Name Description
clone(out?: QParams3d): QParams3d Create a copy of these parameters.  
computeRange(out?: Range3d): Range3d Compute the range to which these parameters quantize.  
copyFrom(src: QParams3d): void Set x, y, and z from `src.  
isQuantizable(point: Point3d): boolean Return true if the point point is quantizable using these parameters.  
setFromOriginAndScale(origin: Point3d, scale: Point3d): void Initialize from origin and scale  
setFromRange(range: Range3d, rangeScale: numberQuantization.rangeScale16): void Initialize these parameters to support quantization of values within the specified range.  
unquantize(x: number, y: number, z: number, out?: Point3d): Point3d Return the unquantized point for the input components.  
fromNormalizedRange(rangeScale: numberQuantization.rangeScale16): QParams3d Static Creates parameters supporting quantization of values within the range [-1.0, 1.0].  
fromOriginAndScale(origin: Point3d, scale: Point3d, out?: QParams3d): QParams3d Static Creates parameters supporting quantization of values within the range [-1.0, 1.0].  
fromRange(range: Range3d, out?: QParams3d, rangeScale: numberQuantization.rangeScale16): QParams3d Static Creates parameters to support quantization of values within the specified range.  
fromZeroToOne(rangeScale: numberQuantization.rangeScale16): QParams3d Static Creates parameters supporting quantization of values within the range [0.0, 1.0].  

Properties

Name Type Description
origin Readonly Point3d The origin of the quantization range.  
rangeDiagonal Accessor ReadOnly Vector3d The diagonal of the unquantized range represented by these parameters.  
scale Readonly Point3d The scale applied to coordinates to quantize them.  

Defined in

Last Updated: 18 January, 2025