SectionDrawingProps Interface

Properties that define a SectionDrawing.

Extends

Properties

Name Type Description
jsonProperties { displaySpatialView?: "true", drawingBoundaryClip?: ClipVectorProps, drawingToSpatialTransform?: TransformProps, sheetToSpatialTransform?: TransformProps } | undefined Optional json properties of this element.  
sectionType SectionType | undefined The type of section used to generate the drawing.  
spatialView RelatedElementProps | undefined The spatial view from which the section was generated.  

Inherited properties

Name Type Inherited from Description
classFullName Inherited string DrawingProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code Inherited CodeProps DrawingProps The Code for this element
federationGuid Inherited string | undefined DrawingProps A FederationGuid assigned to this element.
id Inherited string | undefined DrawingProps The Id of the entity.
isInstanceOfEntity Readonly Inherited undefined | undefined DrawingProps A non-existent property used to discriminate between EntityProps and Entity.
model Inherited string DrawingProps The Id of the Model containing this element
parent Inherited RelatedElementProps | undefined DrawingProps The Parent of this element, if defined.
scaleFactor Inherited number | undefined DrawingProps A factor used by tools to adjust the size of text in GeometricElement2ds in the associated DrawingModel and to compute the
userLabel Inherited string | undefined DrawingProps A user-assigned label for this element.

Defined in

Last Updated: 26 April, 2025