SkySphere Class
Describes how to draw a representation of a sky by mapping a single image to the interior of a sphere.
Extends
Methods
Name | Description | |
---|---|---|
constructor(image: string, gradient?: SkyGradient): SkySphere | Create a new sky sphere using the specified image. | |
toJSON(display?: boolean): SkyBoxProps | See SkyBox.toJSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
createGradient(gradient?: SkyGradient): SkyBox Static Inherited | SkyBox | Create a skybox that displays the specified gradient, or the default gradient if none is supplied. |
fromJSON(props?: SkyBoxProps): SkyBox Static Inherited | SkyBox | Create from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
image Readonly | string | The image to map to the interior of the sphere. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
defaults Static Readonly Inherited | SkyBox | SkyBox | Default settings for a four-color gradient. |
gradient Readonly Inherited | SkyGradient | SkyBox | The gradient settings, used if no cube or sphere images are supplied, or if the images cannot be loaded. |
Defined in
- core/common/src/SkyBox.ts Line 304
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.