TextStyle Class
A named, immutable TextStyleSettings stored in a Workspace.
@see styleName to define the text style for a component of a TextBlock.
@note This is an immutable type. Use clone to create a modified copy.
Methods
Name | Description | |
---|---|---|
clone(alteredSettings: TextStyleSettingsProps): TextStyle | Create a copy of this style with the same name, and settings modified according to the properties defined by alteredSettings . |
|
equals(other: TextStyle): boolean | ||
create(name: string, settings: TextStyleSettings): TextStyle Static | Create a new style. | |
fromJSON(json: TextStyleProps): TextStyle Static | Create a style from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
name Readonly | string | ||
settings Readonly | TextStyleSettings |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.