LineLayoutResult Interface

Represents a single line in a TextBlockLayoutResult.

Properties

Name Type Description
justificationRange Range2dProps Bounding box used when justifying the line.  
offsetFromDocument Readonly<WritableXAndY> The offset of the line from the top and left of the TextBlock.  
range Range2dProps The range containing the contents of the line.  
runs RunLayoutResult[] The runs contained in the line.  
sourceParagraphIndex number The index of the paragraph this LineLayoutResult was generated from in paragraphs.  

Defined in

Last Updated: 21 November, 2024