logException MethodStatic
Log the specified exception. For legacy BentleyError exceptions, the special "exceptionType" property will be added as metadata. Otherwise, all enumerable members of the exception are logged as metadata.
logException(category: string, err: any, log: LogFunction...): void
Parameter | Type | Description |
---|---|---|
category | string | The category of the message. |
err | any | The exception object. |
log | LogFunction | The logger output function to use - defaults to Logger.logError |
Returns - void
Defined in
- core/bentley/src/Logger.ts Line 288
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.