ClassRegistry Class
Maintains the mapping between the name of a BIS ECClass (in "schema:class" format) and the JavaScript Entity class that implements it. Applications or modules that supply their own Entity subclasses should use registerModule or register at startup to establish their mappings.
Methods
Name | Description | |
---|---|---|
constructor(): ClassRegistry | ||
findRegisteredClass(classFullName: string): undefined | Static | Find a registered class by classFullName. | |
getClass(classFullName: string, iModel: IModelDb): Static | Get the Entity class for the specified Entity className. | |
register(entityClass: , schema: ): void Static | Register a single entityClass defined in the specified schema . |
|
registerModule(moduleObj: any, schema: ): void Static | Register all of the classes found in the given module that derive from Entity. |
Defined in
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.