CatalogDb.createNewVersion Function
Create a new version of a CatalogIModel as a copy of an existing version. Immediately after this operation, the new version will be an exact copy of the source CatalogIModel. Then, use openEditable to modify the new version with new content.
createNewVersion(args: CatalogIModel.CreateNewVersionArgs): Promise<{ newDb: CatalogIModel.NameAndVersion, oldDb: CatalogIModel.NameAndVersion }>
@note The write lock must be held for this operation to succeed
Parameter | Type | Description |
---|---|---|
args | CatalogIModel.CreateNewVersionArgs |
Returns - Promise<{ newDb: CatalogIModel.NameAndVersion, oldDb: CatalogIModel.NameAndVersion }>
Defined in
- core/backend/src/CatalogDb.ts Line 295
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.