LockConflict Class
Exception thrown if lock cannot be acquired.
Extends
Methods
Name | Description | |
---|---|---|
constructor(briefcaseId: number, briefcaseAlias: string, msg: "shared lock is held" | "exclusive lock is already held"): LockConflict |
Properties
Name | Type | Description | |
---|---|---|---|
briefcaseAlias Readonly | string | Alias of Briefcase holding lock | |
briefcaseId Readonly | number | Id of Briefcase holding lock |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.