RenderMaterialElementParams Interface
Parameters used to create a RenderMaterial element. The persistent JSON representation - RenderMaterialAssetProps - is quite verbose and unwieldy. This representation simplifies it somewhat.
@see RenderMaterialElement.create and RenderMaterialElement.insert to create a RenderMaterial from parameters of this type.
Extends
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
color Inherited | RgbFactorProps | undefined | RenderMaterialElement.Params | If defined, the color to use for surface fill or diffuse illumination, overriding the surface's own color. |
description Inherited | string | undefined | RenderMaterialElement.Params | An optional description of this RenderMaterial |
diffuse Inherited | number | undefined | RenderMaterialElement.Params | The surface's diffuse reflectivity from 0.0 to 1.0. |
finish Inherited | number | undefined | RenderMaterialElement.Params | The specular exponent describing the surface's shininess, in the range 0 through 128. |
normalMap Inherited | NormalMapProps & { scale?: number } | undefined | RenderMaterialElement.Params | Specifies a normal map to apply to the surface to simulate more surface detail than is present in the |
paletteName Inherited | string | RenderMaterialElement.Params | A required palette name that categorizes this RenderMaterial |
patternMap Inherited | TextureMapProps | undefined | RenderMaterialElement.Params | Specifies a texture image to map onto the surface, replacing or mixing with the surface's own color and transparency. |
reflect Inherited | number | undefined | RenderMaterialElement.Params | Currently unused. |
reflectColor Inherited | number[] | undefined | RenderMaterialElement.Params | Currently unused. |
specular Inherited | number | undefined | RenderMaterialElement.Params | The surface's specular reflectivity from 0.0 to 1.0. |
specularColor Inherited | RgbFactorProps | undefined | RenderMaterialElement.Params | The color to use for specular illumination. |
transmit Inherited | number | undefined | RenderMaterialElement.Params | A transparency to be applied to the surface, ranging from 0 (fully opaque) to 1 (fully transparent). |
Defined in
- core/backend/src/Material.ts Line 268
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.