ElementTreeBottomUp Class
Does a depth-first search on the tree defined by an element and its sub-models and children. Sub-models are visited before their modeled elements, and children are visited before their parents.
The following callbacks allow the subclass to exclude elements and sub-trees from the search:
The visitElement and visitModel callbacks allow the subclass to process the elements and models that are encountered in the search.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(_iModel: IModelDb): ElementTreeBottomUp | ||
processElementTree(element: string, scope: ElementTreeWalkerScope): void Protected | The main tree-walking function | |
shouldExploreChildren(_parentId: string, _scope: ElementTreeWalkerScope): boolean Protected | Return true if the search should recurse into the children (if any) of this element | |
shouldExploreModel(_model: Model, _scope: ElementTreeWalkerScope): boolean Protected | Return true if the search should recurse into this model | |
shouldVisitElement(_elementId: string, _scope: ElementTreeWalkerScope): boolean Protected | Return true if the search should visit this element | |
shouldVisitModel(_model: Model, _scope: ElementTreeWalkerScope): boolean Protected | Return true if the search should visit this model | |
visitElement(elementId: string, scope: ElementTreeWalkerScope): void Protected Abstract | Called to visit an element | |
visitModel(model: Model, scope: ElementTreeWalkerScope): void Protected Abstract | Called to visit a model |
Properties
Name | Type | Description | |
---|---|---|---|
_iModel Protected | IModelDb |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.