onCloned MethodProtected Static
Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel. The transformation process automatically handles remapping BisCore properties and those that are properly described in ECSchema. This callback is only meant to be overridden if there are other Ids in non-standard locations that need to be remapped or other data that needs to be fixed up after the clone.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void
@note If you override this method, you must call super.
Parameter | Type | Description |
---|---|---|
_context | IModelElementCloneContext | The context that persists any remapping between the source iModel and target iModel. |
_sourceProps | ElementProps | The ElementProps for the source Element that was cloned. |
_targetProps | ElementProps | The ElementProps that are a result of the clone. These can be further modified. |
Returns - void
Defined in
- core/backend/src/Element.ts Line 314
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.