ChangesetECAdaptor Class
Transform sqlite change to ec change. EC change is partial change as it is per table while a single instance can span multiple table.
@note PrimitiveArray and StructArray are not supported types.
Implements
Methods
Name | Description | |
---|---|---|
constructor(reader: SqliteChangesetReader, disableMetaData: booleanfalse): ChangesetECAdaptor | Construct adaptor with a initialized reader. | |
acceptClass(classFullName: string): ChangesetECAdaptor | Setup filter that will result in change enumeration restricted to | |
acceptOp(op: SqliteChangeOp): ChangesetECAdaptor | Setup filter that will result in change enumeration restricted to | |
acceptTable(table: string): ChangesetECAdaptor | Setup filter that will result in change enumeration restricted to | |
close(): void | close current instance and it will also close the changeset reader. | |
dispose(): void | dispose current instance and it will also dispose the changeset reader. | |
isECTable(tableName: string): boolean | Check if sqlite change table is a EC data table | |
step(): boolean | Advance reader to next change or a change that meets the filter set in the current adaptor |
Properties
Name | Type | Description | |
---|---|---|---|
debugFlags Readonly | { replaceBlobWithEllipsis: boolean, replaceGeomWithEllipsis: boolean, replaceGuidWithEllipsis: boolean } | set debug flags | |
deleted | ChangedECInstance | undefined | Return partial deleted instance. | |
disableMetaData Readonly | boolean | ||
inserted | ChangedECInstance | undefined | Return partial inserted instance | |
isDeleted Accessor ReadOnly | boolean | Return true if current change is of type "Deleted" | |
isInserted Accessor ReadOnly | boolean | Return true if current change is of type "Inserted" | |
isUpdated Accessor ReadOnly | boolean | Return true if current change is of type "Updated" | |
op Accessor ReadOnly | SqliteChangeOp | helper method around reader.op | |
reader Readonly | SqliteChangesetReader | wrap changeset reader. |
Defined in
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.