DummyCallbackUrlClient Class
A special implementation of a CachedTokenClient whose constructor takes a single callback URL. This will cache the token locally until it has expired based on the expiration time in the URL response.
Extends
Methods
Name | Description | |
---|---|---|
constructor(dummyParams: DummyCallbackUrlParams): DummyCallbackUrlClient | ||
fetch(): Promise<Response> Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getAccessToken(): Promise<string> | CallbackUrlClient | |
getCachedTokenIfNotExpired(freshTokenGetter: AccessTokenWExpirationGetter): Promise<string> Protected | CallbackUrlClient | Returns either a freshToken if there is no cached token or if currently cached token has expired, otherwise it will return a fresh token |
Defined in
Last Updated: 12 September, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.