CallbackClient Class
A special implematation of an AuthorizationClient whose constructor takes a single tokenCallback. This does no additional caching.
Implements
Methods
Name | Description | |
---|---|---|
constructor(tokenCallback: AccessTokenGetter): CallbackClient | ||
getAccessToken(): Promise<string> | Obtain an AccessToken for the currently authorized user, or blank string if no token is available. |
Defined in
- ConnectorAuthenticationManager.ts Line 104
Last Updated: 27 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.