useTrackedPropertyGridModelSource Function
Custom hook that creates a PropertyGridModelSource and subscribes it to data updates from the data provider while also providing information on data update progress.
useTrackedPropertyGridModelSource(props: { dataProvider: IPropertyDataProvider }): { inProgress: boolean, modelSource: PropertyGridModelSource }
@throws if/when IPropertyDataProvider.getData()
promise is rejected. The error is thrown in the React's render loop, so it can be caught using an error boundary.
Parameter | Type | Description |
---|---|---|
props | { dataProvider: IPropertyDataProvider } |
Returns - { inProgress: boolean, modelSource: PropertyGridModelSource }
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.