createGridCategory Method
Converts category into GridCategoryItem.
createGridCategory(category: PropertyCategory, recordsDict: CategoryRecordsDict, parentSelectionKey?: string, depth?: number): IMutableGridCategoryItem
@returns converted GridCategory.
Parameter | Type | Description |
---|---|---|
category | PropertyCategory | PropertyCategory to convert. |
recordsDict | CategoryRecordsDict | dictionary of category records. |
parentSelectionKey | string | parent selection key of this category. |
depth | number | current depth counting from root category. |
Returns - IMutableGridCategoryItem
converted GridCategory.
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.