addWidgetDef Method
Adds a WidgetDef for use in a Frontstage.
addWidgetDef(widgetDef: WidgetDef, stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection): boolean
@note Added widgetDef
must return unique id to correctly save/restore App layout.
Semi-stable id is generated when auto-generated widgetDef
id is detected,
but correctness of such id depends on addWidgetDef
call order and widget location.
Parameter | Type | Description |
---|---|---|
widgetDef | WidgetDef | |
stageId | string | |
stageUsage | string | |
location | StagePanelLocation | |
section | StagePanelSection |
Returns - boolean
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.