initialize MethodStatic
Overloads | |
---|---|
initialize() Static | |
initialize(store, frameworkStateKey?) Static | Deprecated |
initialize()
Called by the application to initialize the UiFramework. Also initializes UIIModelComponents, UiComponents, UiCore.
initialize(): Promise<void>
Returns - Promise
initialize(store, frameworkStateKey?)
Deprecated in 4.15.0. Continue using redux initializer until all application components react to redux deprecations. Use overload without parameters instead.
Called by the application to initialize the UiFramework. Also initializes UIIModelComponents, UiComponents, UiCore.
initialize(store: Store<any, AnyAction>, frameworkStateKey?: string): Promise<void>
Parameter | Type | Description |
---|---|---|
store | Store<any, AnyAction> | The single Redux store created by the host application. If this is undefined then it is assumed that the StateManager is being used to provide the Redux store. |
frameworkStateKey | string | The name of the key used by the app when adding the UiFramework state into the Redux store. If not defined "frameworkState" is assumed. This value is ignored if StateManager is being used. The StateManager use "frameworkState". |
Returns - Promise
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.