getWidgets MethodStatic
Called when the application is populating the Stage Panels so that any registered UiItemsProvider can add widgets
getWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, zoneLocation?: AbstractZoneLocation, stageAppData?: any): ReadonlyArray<AbstractWidgetProps>
@returns An array of AbstractWidgetProps that will be used to create widgets.
Parameter | Type | Description |
---|---|---|
stageId | string | a string identifier the active stage. |
stageUsage | string | the StageUsage of the active stage. |
location | StagePanelLocation | the location within the stage. |
section | StagePanelSection | the section within location. |
zoneLocation | AbstractZoneLocation | |
stageAppData | any |
Returns - ReadonlyArray<AbstractWidgetProps>
An array of AbstractWidgetProps that will be used to create widgets.
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.