AbstractWidgetProps Interface
Deprecated in 3.6. Use Widget instead.
Properties for a Widget.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
allowedPanelTargets Readonly | ReadonlyArray<"left" | "right" | "bottom" | "top"> | undefined | Optional prop specifying which Panel sides can be docking targets for this widget. | |
applicationData Readonly | any | undefined | Application data attached to the Widget. | |
badgeType Readonly | BadgeType | undefined | Badge to be overlaid on the widget tab. | |
canPopout Readonly | boolean | undefined | Indicates if widget can be popped out to a child window. | |
defaultFloatingPosition Readonly | { x: number, y: number } | undefined | Defines that default Top Left position when widget is floated via API calls | |
defaultFloatingSize | { height: number, width: number } | undefined | Optional default size to use when floating a widget. | |
defaultState Readonly | WidgetState | undefined | Default Widget state. | |
fillZone Readonly | boolean | undefined | Indicates whether this Widget should fill the available space in the Zone. | |
floatingContainerId Readonly | string | undefined | If the widget state is changed to floating and the floatingContainerId is defined, the widget will be added to a |
|
getWidgetContent Readonly | () => any | Gets the widget content. | |
hideWithUiWhenFloating | boolean | undefined | Optional prop that tells the widget system to fade this widget out with the rest of the UI when it is in floating state | |
icon Readonly | string | ConditionalStringValue | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. | |
id Readonly | string | undefined | Id used to uniquely identify the widget. | |
internalData Readonly | Map<string, any> | undefined | optional data to used by item implementor. | |
isFloatingStateSupported Readonly | boolean | undefined | Indicates if widget can be in floating state, default to true. | |
isFloatingStateWindowResizable Readonly | boolean | undefined | Indicates if floating widget is resizable, defaults to false which caused the widget to be auto-sized.. | |
isFreeform Readonly | boolean | undefined | Indicates whether the Widget is free-form or rectangular. | Deprecated |
isStatusBar Readonly | boolean | undefined | Indicates whether this Widget is for the Status Bar. | |
isToolSettings Readonly | boolean | undefined | Indicates whether this Widget is for the Tool Settings. | |
label Readonly | string | ConditionalStringValue | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. | |
onWidgetStateChanged Readonly | () => void | undefined | Handler for widget state changed event | |
priority Readonly | number | undefined | Widget priority | |
restoreTransientState Readonly | () => boolean | undefined | Restore transient DOM state. | |
saveTransientState Readonly | () => void | undefined | Save transient DOM state (i.e. | |
stateFunc Readonly | (state: Readonly<WidgetState>) => WidgetState | undefined | Function executed to determine the state of the widget. | Deprecated |
syncEventIds Readonly | string[] | undefined | Defines the SyncUi event Ids that will trigger the stateFunc to run to determine the state of the widget. | |
tooltip Readonly | string | ConditionalStringValue | used to explicitly set the tooltip shown by a component. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
providerId Readonly Inherited | string | undefined | ProvidedItem | id of UiItemsProvider |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.